Back to overview
Resolved

API partly malfunctioning

Jun 6, 2026 at 11:32am UTC
Affected services
API

Resolved
Jun 6, 2026 at 2:34pm UTC

We have identified the root cause of the issue and deployed a fix, the API is fully operational again. A misconfiguration in the exchange rate API manifest was deployed on May 23, 2026 at 0:47 AM UTC that attached the exchange rate API to a private overlay network, cutting of the service's access to in/outbound public internet. For the brief moment between May 23, 2026 23:23 PM UTC and May 23, 2026 0:47 AM UTC, the service utilized the window to backfill currency pair rates but was hindered from doing so after the manifest update. Today this problem showed itself in the production cluster after a container restart. Changes have been deployed to the MUN API to prevent a future similar scenario from degrading the API's performance.

Created
Jun 6, 2026 at 11:32am UTC

The API is currently experiencing degraded performance, with some endpoints not functioning as expected. The incident has been automatically escalated to team.